Using Advanced Features of Visio
When you began using Visio, you learned about Visio, how it worked, and what it did.
You were taken through the basics of creating a diagram from scratch or by using preexisting templates. You learned how Visio could be used to help with presentations
and to improve documents.
Now that you have the basics, you need to know how to take that diagram, flowchart,
or whatever you created, manipulate it, change it, and add data to it.
In this ReferencePoint, you will learn how to take a previously saved diagram, chart,
or whatever you created, input data into it, manipulate the data, graphics, and
structure, and importing data from other programs to work within Visio.
Now that you have created your first diagram, the next step is to build the diagram by
adding more shapes, adding text to the shapes, and giving the diagram a title. If your
diagram is a flowchart, or organization chart, you will also want to connect related
shapes.
As you build your diagram, you will need to rearrange, resize, or rotate shapes, and,
perhaps, add color to the background.

Open a Saved Diagram File
In figure one is a saved diagram about the development of a network. Notice how
everything is strategically placed.

This figure represents a typical saved diagram done in Visio.

You can open a previously saved diagram file in the same way that you open other
files. You can identify Visio diagram files by the distinctive icon and the VSD file
extension.
To open a saved diagram file:

1.

Click the Start button, point to Programs, and then clickMicrosoft Visio.

2.

On the File menu, click Open.

3.

In the Look in list, open the folder that contains the file you want to open.

If you already have Visio opened, on the File menu, click the name of the file from the
list of recently opened files at the bottom of the menu. If the file you want to open is
not listed, click Open, navigate to the file, select it, and then click Open.
Although, a diagram has certain shapes and connections in place, it does not mean
that you cannot add more shapes or change the ones you have.
That is the power of Visio. Unlike some programs that can not be altered after a
document has been created, Visio provides the ability to manipulate any image,
shape, connector, or text.
This will be demonstrated as you work with Visio and learn to harness its vast power
and capabilities.

Using Shapes
In Visio, having worked with shapes to create your document, you know it is the
primary tool that is used to assemble any diagram. To find a shape to add you just
have to look at the subjects, which are stored in areas called stencils.
As you know, a stencil is a container for shapes. Seefigure two for a sample of a
stencil.

This figure shows an example of a stencil.
Looking at the figure you can see:
1)

A identifies the stencil.

2)

B is the area that contains the shapes to create the diagram.

3)
C is the shape that can be used in the diagram. All you have to do is grab a
shape with the mouse and drag it to the drawing page and drop it in place.
4)
If you right-click the title bar, you will see what is depicted as in D. Here you
have a menu of choices, where you can change the shape or perform other activities.
5)

Of course, E points to the scroll bar that allows you to see more shapes.

Using Stencils
When you created your document, you opened a template initially, which
automatically opened stencils that contained the right shapes you wanted for the
diagram you created. For example, when opening the Networking template it
included:
Basic Networking Shapes stencil, which contains all of the shapes you need to
assemble a basic network.

Backgrounds stencil, which contains 18 unique background designs that you
can add to your diagram simply by dragging a shape onto the page.
Borders and Titles stencil, which contains decorative borders and titles that you
can use to brighten up your diagram.
The Basic Networking template includes three stencils. By default, when you open a
template, the stencils are aligned vertically along the left side of the drawing page.
To use shapes in your diagram that are not included in the stencils of a template,
open additional stencils. For example, to add a date to your diagram, you open the
forms stencil and drag the "Today's Date" shape on to the drawing area of your
diagram.
Table one shows a table describing various ways to use stencils.
Move to Make

How to achieve it

Add a shape to a diagram

Drag a shape from a
stencil onto the drawing
page.

View the shapes on a
different stencil.

Click the stencil's gray title
bar to display its shapes.

Open a new stencil.

1.
On the File menu,
point to stencils, and then
click Open Stencil.
2.
Double-click the
folder you want to open.
3.
Select the stencil,
and then click Open.

Connecting Shapes
Flowcharts, organization charts, any type of diagram is based on relationships. A
flowchart, for example, shows sequential steps in a process. An organization chart
shows who reports to whom.
To show a relationship in a Visio diagram, you have to use and connect two twodimensional (2D) shapes with a third, one-dimensional (1D) shape called a
"connector." Connectors at first appear to be simple lines, but they are "smart." They
not only connect two shapes together, but they also can be attached to the shapes.

This means that you can move connected shapes without breaking the connection.
This can be seen visually by looking atfigure three.

This figure shows a flowchart with connectors showing relationships between shapes.
To understand how these connectors work, it would be best to show the different type
of connectors, how they look, and how they can be used.

Shape Elements
There are two types of shapes to contend with - endpoints and connection points.
Endpoints are points on the ends of connectors used to attach connectors to other
shapes.

This figure shows a connector. Notice the endpoints are the green squares with the x
inside.
Connection points are places on 2D shapes which you can attach connector endpoints.

This figure shows a 2D shape with connection points shown as an X.
Where you see the X is where the endpoints of the 1D connectors get connected.
When an endpoint is attached to a specific connection point on a shape it looks like
this:

Notice the x inside the red box. The x in the red box shows where the shape is
attached to the 2D shape.
When an endpoint is attached to a specific connection point, it stays connected to that
specific connection point even if the shapes are moved.
When an endpoint is attached like this:

Notice there is no x inside the box. This shows that the 1D connector or endpoint is
attached to the entire shape, not just where the X is. This means that when the
shape moves, the endpoint shifts to the closest connection point.

Dealing with Shapes
When a diagram is saved and reopened, you may think the shape cannot be moved.
That is a wrong assumption. A shape can be moved anywhere on the drawing or
diagram. Look at the two pictures below:

Figure showing two drawings of diagrams with the shapes having been moved.
If you look at the two pictures, you can see how the shapes were moved. The first
yellow shape was moved to the side of the red shape. Also, notice the connector and
how it readjusted itself to conform to the rearrangement.
The third yellow shape was dragged over to be under the second yellow shape. Again,
notice the connector and how it moved. Finally, the green shape was moved down to
be almost even with the second green shape.
Throughout all these movements you can see how the connectors repositioned
themselves to the new shape's position.
Take a look at another example of moving shapes. Figure four gives a view of a
flowchart for this example.

This figure shows shapes rearranged. Notice the connectors.
It does not matter what shape you place on the drawing and where you place the
connector. When you move the shape or shapes, everything reorganizes according to
the realigned format.
Examine another diagram. Look atfigure five:

This figure shows a diagram of an office.
Notice the diagram, the placement of all shapes and connectors. Remember, you can
move any shape in any diagram you create and any connector that is attached to the
shape will realign itself.
Look atfigure six and notice how shapes have been moved and added.

This figure shows shapes having been moved and some were added.
The basic premise here, you can do many things to shapes. You can add a shape in a
drawing, save it, and alter it later. Visio has the power and flexibility to do whatever
you need it to do, whether it is developing flowcharts, organization charts, etc.
You were shown that you can change shapes, move them around, etc. The way to
move a shape you have to move the pointer over the shape you want to move and
drag it to the position you want. The grid lines guide you in moving the shape.
If you just want to change the size of the shape, drag a selection handle, if the shape
is two-dimensional, otherwise, drag an endpoint. This can be seen by looking atfigure
seven.

This figure shows small green boxes called endpoints (on 1D shapes) or selection
handles (on 2D shapes). To change the size of the shape, drag one of these squares.
After you put the shape on the drawing page, you may want to rotate it. There are
three ways to rotate a shape.
Rotation tool
On the Standard toolbar, click the Rotation tool, and then click the shape you want to
rotate. Place the pointer over one of the round rotation handles at the corners or ends
of the shape. This can be seen infigure eight.

This figure shows the rotation tool in action.
Using the Size & Position window
To rotate a shape using the Size and Position window select the shape you want to
rotate. On the View menu, click Size & Position Window.
In the Angle box, type the amount of rotation you want, and then press ENTER. This
can be seen infigure nine.

This figure shows the Size and Position window being used.
Rotate menu commands
To use the Rotate menu commands option just select the shape you want to rotate.
On the Shape menu, point to Rotate or Flip, and click Rotate Left or Rotate Right. This
can be seen infigure 10.

This figure shows the Rotate menu command being used.
As you can see, you have various ways of working with shapes on the drawing board,
which means you do have a choice. If you have a preference of one type over

another, you have it with in your means to make that choice.
Visio provides great flexibility in the way the program can be used. You are not
confined to using only one method over another. You can be adaptable just as Visio
can be.

Working with a Diagram
In the Visio diagram you assemble, you will need to include text in at least some of
the shapes. In a flowchart, for example, add text to describe what process each
shape represents. This can be seen infigure 11.

This figure shows a flowchart diagram with words added in the shapes.
In order to add words to shapes you have to perform the following actions:
To add new text - Select the shape you wish to add text to, then type. When you are
done typing, click outside the shape.

If you want to edit existing text - Double-click the shape containing the text you want
to edit. To replace the existing text, type any new text. If you just want to revise the
existing text, click in the text where you want to start typing. When you have finished
typing, click outside the shape.
If you want to change the font size, color, or style, select the shape with the text you
want to change. Click the Format menu, then click Text. In the TEXT dialog box,
choose the options you want, and then click OK as seen infigure 12.

This figure shows the font tool in action.
Here are the results from using the font tool in figure 12.

This figure shows the results of using the font tool in Visio.
If you want your text to appear fancy, like making it appear in a certain way across
the screen, follow these steps:
1.

Double-click the shape that contains the text you want to change

2.

Right-click in the area surrounded by the green dashed line.

3.
On the shortcut menu, point to Horizontal Alignment and/or Vertical
Alignment, and then select the alignment you want.
Seefigure 13 for an example of this step.

This figure shows how to use the horizontal alignment tool.

Add a Title to a Diagram
The title to a diagram tells the user what the subject and purpose of the diagram will
be, plus more. The title also adds a decorative flair to the diagram.
To add a title to a diagram is to drag one of the pre-designed title block shapes from
the Borders and Titles stencil onto the drawing page as shown infigure 14.

This figure shows the diagram with a title added.
There are 14 pre-designed title block shapes from the Borders and Titles stencil you
can use. Use them to make a difference in your diagram. This way or presentation
will stand out from the rest.
You saw an example of how a title can be added to a diagram. Now here is the exact
procedure to follow to accomplish this task:
With the diagram open, click the title bar of the Borders and Titles stencil to
display its shapes.
If you do not see the Borders and Titles stencil, on the File menu, point to
Stencils, point to Visio Extras, and then click Borders and Titles.
Scroll down until you can see all of the title block shapes on the stencil.
Drag a title block shape onto the drawing page, and then position it where you
want.
Double-click the title block shape. Click to select the text you want to change,
and then type your own information.

Tip If you inadvertently delete the current date or delete something you did not
intend to, drag a new shape from the stencil.
Click outside the shape.

Dealing with the Background
You designed your diagram. You have everything in place. But, there is still
something missing. In order for a diagram to look good, you need to have a
spectacular background that will spice it up. By choosing the right color and design,
you can dramatically improve your diagram's appearance.
One point to note here is that if you apply a color scheme to a diagram, you change
the colors of all the shapes simultaneously.
In order to add a background design to your diagram, just drag and drop one of the
18 pre-designed background shapes from the Backgrounds stencil as seen infigure 14.

This figure shows a diagram with a background being added.
In order to remove the background, either click undo from the main menu, or locate
the background (none) icon and drag that over to your diagram.
Here is what you would do if you wanted to add or change the color scheme.
Place the mouse on the drawing page and right-click, bringing up the shortcut
menu.

Click Color Schemes.
Select a color scheme, and then click Apply to see how the colors look.
When you find a color scheme you want, click OK.

